Home Live Radio Podcast Live TV Vodcast Forum Files Login Register :     Contact : 
 
Forum index Forum: Penbex Radio device analysis Topic: AKIRA MCB04W@U does not turn on the menu ' Last replied to: April 9, 2014, 10:01 pm Back to post view
AuthorPostOptions
Posted by robyradio Message # 1     Posted at March 28, 2014, 6:08 pm,     subject: AKIRA MCB04W@U does not turn on the menu '  
Messages: 10 posts
Registration date: March 12, 2014
Status: Offline

Hi,
I just bought this model but I have a great problem
When I press the button on... the screen turns blue
 but the menu 'never comes
Exists a sequence of keys to make it start .... or there is no remedy?
Thank you very much
Robyradio
 
Posted by penbex Message # 2     Posted at March 28, 2014, 7:46 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 2261 posts
Registration date: May 21, 2009
Status: Offline

You can try the firmware recovery.
It is explained already on the forum.
You will need a USB A-A cable (both ends of the cable the same connector)
 
Posted by robyradio Message # 3     Posted at March 29, 2014, 3:34 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 10 posts
Registration date: March 12, 2014
Status: Offline

I'm doing some tests. something strange is happening


(Last Edited by robyradio on March 30, 2014, 10:43 pm)
 
Posted by robyradio Message # 4     Posted at March 29, 2014, 5:35 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 10 posts
Registration date: March 12, 2014
Status: Offline

Hi,
I am here again
After an hour
of blue screen. The menu has arrived. You can see the details of info
F / W Ver.2.0.0
uP Ver: 0x25
OS Ver:
KW-1004-IPMICRO-beta build 2.0.023
01/26/11-1403
Now everything works ok
But .....
If I turn it off. and then I remove the plug from the 220v.
When I turn it on again within a few minutes can start with the menu ok.
If I wait more time the menu will not start.
This time the menu' is arrived .....but I do not know for the future
From
what can happen this
Electronic problem, or something else? It could be caused by an internal battery that is low (if it exists ...)
I'm looking on the forum all the instructions to make firmware recovery
What is the right boot loader for my akira?
Thanks



(Last Edited by robyradio on March 30, 2014, 10:57 pm)
 
Posted by robyradio Message # 5     Posted at March 31, 2014, 5:51 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 10 posts
Registration date: March 12, 2014
Status: Offline

Quote:
You can try the firmware recovery.
It is explained already on the forum.
You will need a USB A-A cable (both ends of the cable the same connector)
Ok I made a few steps. I tried my Akira connected to the PC with USB AA.All Ok! then
I downloaded ListenLive Firstaid kit and I put on a 2GB SD card. but I do not
I know if I can with my Loader to start the recovery. You can check the details of my Akira
and
provide me if I need to change loaders and where to find it and to change it if I proceed to load it on SD.
I pay attention to everything .... almost looks like a birth of baby ha ha

Thank you ...
 
Posted by penbex Message # 6     Posted at March 31, 2014, 6:29 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 2261 posts
Registration date: May 21, 2009
Status: Offline

the first aid kit is NOT for Penbex devices. It is for the SkyTC devices!

What you need to do with the USB cable is a firmware recovery if you can not get into the normal firmware anymore.
If you can get into the firmware you can use the regular update as well.

What you can update from the regular mode is both the firmware and the bootloader..
I would start with doing this.
put the colilo.upg and the 2.0.0.23 on a usb stick or sd card and perform the update.. first of the colilo then of the firmware.
Power off and keep it off for a while.
power on and if it starts quickly all is ok.
If it still takes a very long time one of the self tests is having problems.. which means one of the hardware items has problems.
Is the fan still runing? is the CD tray detected correctly (open/close)...

 

 
Posted by robyradio Message # 7     Posted at April 1, 2014, 5:17 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 10 posts
Registration date: March 12, 2014
Status: Offline

Quote:

the first aid kit is NOT for Penbex devices. It is for the SkyTC devices!

What you need to do with the USB cable is a firmware recovery if you can not get into the normal firmware anymore.
If you can get into the firmware you can use the regular update as well.

What you can update from the regular mode is both the firmware and the bootloader..
I would start with doing this.
put the colilo.upg and the 2.0.0.23 on a usb stick or sd card and perform the update.. first of the colilo then of the firmware.
Power off and keep it off for a while.
power on and if it starts quickly all is ok.
If it still takes a very long time one of the self tests is having problems.. which means one of the hardware items has problems.
Is the fan still runing? is the CD tray detected correctly (open/close)...

 

Hi Penbex ,
-- I have put in the loader colilo.
-- I have not changed the firmaware because I already have the 2.0.0.23
Nothing has changed , the menu comes after about an hour of blue screen.
After about an hour I try to turn it on and after several attempts finally the start menu . (For now It has always done this) .
You said "Is the fan still runing ? Correctly detected is the CD tray ( open / close ) ... "
- The fan .... I do not hear anything on the inside. Nothing when is as blue screen and nothing when everything is working ok .
 
- The CD also it seems to work well (when the AKIRA is working) .
When the situation is in blue screen
nothing works ... it does not work the combination of " power + UP" to go into USB UPGRADE .
The USB upgrade only works when the menu is arrivato. I switch off and then " power + up" and you see USB Upgrade.

But the question is this ..... when the loader starts and it does its test and probably something fails .... and then finally start ....
because if I turn it off and then I power again within a few minutes everything is ok ?
Also
in the case of 2' switch should do the usual tests. It would seem that something in the boot memory does not go
Thank you for your patience

 
Posted by penbex Message # 8     Posted at April 1, 2014, 6:26 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 2261 posts
Registration date: May 21, 2009
Status: Offline

Quote:
-- I have not changed the firmaware because I already have the 2.0.0.23

The idea was to reload both the loader and the firmware to make sure there are no errors in the firmware as stored in flash memory.
Quote:

- The fan .... I do not hear anything on the inside. Nothing when is as blue screen and nothing when everything is working ok .


On the back of the Akira there is a 40 x 40 mm ventilation outlet.. right behind it there is a fan..
it should run and yhou should be able to hear it well as one of the weak points of the Penbex machines is the loud fan.
If it is not running, it is possible the device got overheated and has some issues due to that (like loose contacts on the mainboard?)

Quote:

But the question is this ..... when the loader starts and it does its test and probably something fails .... and then finally start ....
because if I turn it off and then I power again within a few minutes everything is ok ?
Also
in the case of 2' switch should do the usual tests. It would seem that something in the boot memory does not go
Thank you for your patience


Power on for the first time is a cold boot. The device boots and does a self text. It probably hangs on some hardware state. When that hardware is finaly working it resumes booting and starts to work.
When you power on for the second time you do like a warm boot. .the problem part is then already warm and working.. and thus ther is no issue.
At least.. that is what it looks like.

~William

 

 
Posted by robyradio Message # 9     Posted at April 3, 2014, 6:46 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 10 posts
Registration date: March 12, 2014
Status: Offline

Hi Penbex,
I tried to replace firmware and loader for 2 times but nothing news everything was as before.
No trace of the fan  there is a grid 4x4cm behind AKIRA to accommodate a fan  but there is
no fan inside not fan out of the machine and when AKIRA is on .... the silence is absolute.
In the coming days I try to go back to the store where I bought it to see if they have others
available
for change. I'll let you 'know ....
Really thanks for you help
 
Posted by robyradio Message # 10     Posted at April 8, 2014, 7:51 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 10 posts
Registration date: March 12, 2014
Status: Offline

Hi Penbex,
I finally changed my Akira. Now when I turn it on the menu arrives. All ok! The details are:
-----------------
F / W 1.0.3
uP Ver: 0x25
OS ver
KW-1004-AKIRA-1.0.3.59
8.15.08 build 1740
-------------
I can not update anything via USB
When I try with USB UPGRADE I can put the file
in memory of Akira, but when I unplug the USB 
it does not happen nothing
and the screen remains with USB UPGRADE
Do you have any idea?
thanks
Robyradio
 
Posted by penbex Message # 11     Posted at April 8, 2014, 10:00 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 2261 posts
Registration date: May 21, 2009
Status: Offline

use windows, not Linux.
Use eject via the file manager, do not eject via the taskbar.
that should solve it

 
Posted by robyradio Message # 12     Posted at April 8, 2014, 10:45 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 10 posts
Registration date: March 12, 2014
Status: Offline

Yes I use windows and use eject via the file manager.

In this new AKIRA There is this informations
F / W 1.0.3
uP Ver: 0x25
OS ver
KW- 1004- AKIRA - 1.0.3.59
8.15.08 build 1740
-------------
The old instead
F / W Ver.2.0.0
uP Ver: 0x25
OS Ver:
KW- 1004- IPMICRO - beta build 2.0.023
01/26/11-1403
---------------
One question ..
The section F / W x.x.x. is the reliase of Loader ?
In my old Akira I had  F/W 2.0.0 and with it i
could changade the firmware....
In this new Akira i
tried ..... but does not work with USB and does not work with USB UPGRADE .
I can not change not Loader and not Firmware
When I try by USB (with loader colilo) appears on the screen the message ..... proofing ..... then just a 1second  firmware upgrade screen and then restarts (can not load the firmware in such a short time 1-2 seconds)
With the Firmware 2.0.0.23 is the same.
When I try to USB UPGRADE .. same ... firmware upgrade. 2 seconds and then starts again .
One question ... possible the loader that I have does not allow for updates .... Or in the release that I have of the firmware ( 1.0.3.59 ... ? Never known this ...?)
Could be written into a "release value" greater than that which is in the 2.0.0. 23 and for this reason  is not loaded the new because it is considered to be older?
I'm sorry for my english
Thank you William
 
Posted by penbex Message # 13     Posted at April 9, 2014, 9:26 am,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 2261 posts
Registration date: May 21, 2009
Status: Offline

Hello,

I have no idea what you are trying to do.. but you can NOT update from an Akira to an IPMicro firmware just like that.
You need to check what is printed @ settings/information scroll down to OS Ver:

If there is "Akira" printed there.. you need to update to the Akira 2.0.0.23..

 
Posted by robyradio Message # 14     Posted at April 9, 2014, 1:43 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 10 posts
Registration date: March 12, 2014
Status: Offline

Quote:

Hello,

I have no idea what you are trying to do.. but you can NOT update from an Akira to an IPMicro firmware just like that.
You need to check what is printed @ settings/information scroll down to OS Ver:

If there is "Akira" printed there.. you need to update to the Akira 2.0.0.23..

OK maybe I did a little bit of confusion with my english, sorry.
Now my only problem is to update the loader and the firmware of my Akira.

I have this situation

F / W 1.0.3
uP Ver: 0x25
OS ver
KW- 1004- AKIRA - 1.0.3.59
8.15.08 build 1740

I'm not able with normal upgrades (USB) and even with USB UPGRADE to load the 2.0.0.23

Roby


 
Posted by robyradio Message # 15     Posted at April 9, 2014, 5:25 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 10 posts
Registration date: March 12, 2014
Status: Offline

Finally!! all ok
I found http://duncan.turtleradio.com/dlpage.php?page=4
KW-1004-akira-1.0.3.62 Original firmware for the Akira Radio Device.
My Akira has loaded this firmware!!
This unlocked my Akira and so
I have upgraded with http://www.listenlive.nl/dlpagemod.php?page=1
KW-1004-akira-2.0.0.23
New firmware for the Akira MCC-B04W @ U - Micro Chaine AKUB WiFi Internet Radio.

And so all good now works great!!

The only thing is that... in the Akira System Info is arrived
F / W Ver 2.0.0
OS Ver:
KW-1004-IPMICRO-beta build 2.0.023
Probably inside the firmware is written this information, but everything is fine!
William Thank you so much for your help


 
Posted by penbex Message # 16     Posted at April 9, 2014, 10:01 pm,     subject: AKIRA MCB04W@U does not turn on the menu  
Messages: 2261 posts
Registration date: May 21, 2009
Status: Offline

duncan.turtleradio is also our server