Home Live Radio Podcast Live TV Vodcast Forum Files Login Register :     Contact : 
 
Forum index Forum: Device: AudioTron Topic: Making Atron work with Windows 7 and above Last replied to: Never Back to post view
AuthorPostOptions
Posted by kdurigan Message # 1     Posted at May 20, 2018, 8:39 pm,     subject: Making Atron work with Windows 7 and above  
Messages: 5 posts
Registration date: May 19, 2018
Status: Offline

I have been unable to get the atron to work directly against Windows 7/10 shares, at least when those shares are hosted on domain joined machines.  It used to, mind you, but no longer and I suspect tighter security being the cause.  I have been successful cheating by configuring my router to mount the Windows share using CIFS and Samba.  The router can talk to the Windows machine and the audiotron points at the share on the router.  There are a few key things to note:

On the Windows PC
  • Enable NTLMv1 - secpol..msc -> local policies -> security options -> Send LM and NTLM - use NTLM v2 session security if negotiated
  • Enabled SMB1 - Changed HKLM\system\currentcontrolset\services\lanmanserver\parameters\SMB1=0 to SMB1=1
  • Enabled File server optimizations instead of workstation optimizations (required or lanman runs out of memory)
    • Changed HKLM\system\currentcontrolset\services\lanmanserver\parameters\size=1 to size=3
  • Added local account that has USER access only - gives router access to music share

Router changes

  • On Services -> USB tabs: Enabled core USB support, USB storage and automatic drive mount options.  Although no USB support is required it allows me to plug in drives and index them on the atron.
  • On Administration -> Automount CIFS:
    • Enabled CIFS
    • Share: //Server/share/music
    • Username: atron
    • Password: xxxxx (This is the local account defined on the windows "server")
  • On Services -> NAS tabs, File sharing:  (note, plug in USB drive when creating the share)
Path: /mnt/sda1             Name: USB     Public: checked    Access: read-only
Path: /mnt/smbshare     Name: Music   Public: checked    Access: read-only

Save the config and reboot the router.  To check share visibility, run:  net view \\routername


Atron changes
  • Configure the share to point at the router \\routername\music
Everything works like a champ now!